Report board software problems here

OT: anything goes!

Moderator: Edi

User avatar
Elheru Aran
Emperor's Hand
Posts: 12400
Joined: 2004-03-04 01:15am
Location: Georgia

Re: Report board software problems here

Post by Elheru Aran » 2016-04-28 05:09pm

Here...
https://www.facebook.com/groups/2221698587/

Granted, it's not a very active page, but it's useful for checking if the board is down since Facebook will hardly ever go down. So if the board doesn't come up for you on multiple browsers or your phone, just ask. That's what I did. There's also the very occasional discussion there as well.
It's a strange world. Let's keep it that way.

User avatar
Dominus Atheos
Sith Marauder
Posts: 3719
Joined: 2005-09-15 09:41pm
Location: Portland, Oregon

Re: Report board software problems here

Post by Dominus Atheos » 2016-04-30 06:43pm

Test.
Spoiler
Test
Is this text small? It's not supposed to be.

User avatar
Dominus Atheos
Sith Marauder
Posts: 3719
Joined: 2005-09-15 09:41pm
Location: Portland, Oregon

Re: Report board software problems here

Post by Dominus Atheos » 2016-04-30 06:44pm

Yes, yes it is.

So text after spoilers is small for some reason.

User avatar
Dominus Atheos
Sith Marauder
Posts: 3719
Joined: 2005-09-15 09:41pm
Location: Portland, Oregon

Re: Report board software problems here

Post by Dominus Atheos » 2016-04-30 06:49pm

Size 150 text

Normal sized text.
Spoiler
Stuff
Size 150 text.

Size 120 text?

User avatar
Crazedwraith
Emperor's Hand
Posts: 10519
Joined: 2003-04-10 03:45pm
Location: Cheshire, England

Re: Report board software problems here

Post by Crazedwraith » 2016-08-12 04:33am

All youtube videos seem to be non-functional now. Replaced by a vertical black bar.
To the brave passengers and crew of the Kobayashi Maru... sucks to be you - Peter David

User avatar
Iroscato
Jedi Council Member
Posts: 2326
Joined: 2011-02-07 03:04pm
Location: Great Britain (It's great, honestly!)

Re: Report board software problems here

Post by Iroscato » 2016-08-12 05:22am



Seems fine to me...
Yeah, I've always taken the subtext of the Birther movement to be, "The rules don't count here! This is different! HE'S BLACK! BLACK, I SAY! ARE YOU ALL BLIND!?

- Raw Shark

Destiny and fate are for those too weak to forge their own futures. Where we are 'supposed' to be is irrelevent.

- SirNitram (RIP)

User avatar
Crazedwraith
Emperor's Hand
Posts: 10519
Joined: 2003-04-10 03:45pm
Location: Cheshire, England

Re: Report board software problems here

Post by Crazedwraith » 2016-08-12 05:32am

could just be me but I'm still just seeing a black bar in your post.
To the brave passengers and crew of the Kobayashi Maru... sucks to be you - Peter David

Malagar
Youngling
Posts: 79
Joined: 2010-03-08 03:38pm
Location: Denmark

Re: Report board software problems here

Post by Malagar » 2016-08-12 07:11am

I can get the embedded videos to work on my phone, but not my work pc, so it's apparently limited to certain systems.

User avatar
Crazedwraith
Emperor's Hand
Posts: 10519
Joined: 2003-04-10 03:45pm
Location: Cheshire, England

Re: Report board software problems here

Post by Crazedwraith » 2016-08-12 09:43am

Malagar wrote:I can get the embedded videos to work on my phone, but not my work pc, so it's apparently limited to certain systems.
Yeah it's working on my phone's chrome. But not my work laptop (IE) or my home pc (Chrome again)
To the brave passengers and crew of the Kobayashi Maru... sucks to be you - Peter David

User avatar
SpottedKitty
Jedi Knight
Posts: 894
Joined: 2014-08-22 08:24pm
Location: UK

Re: Report board software problems here

Post by SpottedKitty » 2016-08-12 11:06am

No difference in embedded YouTube video behaviour here (Firefox, current version); either it works, or I see only a blank space (not a black bar), and sometimes they start working later on, either on re-viewing the page or in a reply. Totally at random, as far as I can tell.
“Despite rumor, Death isn't cruel — merely terribly, terribly good at his job.”
Terry Pratchett, Sourcery

User avatar
Lord Revan
Emperor's Hand
Posts: 10970
Joined: 2004-05-20 02:23pm
Location: Zone:classified

Re: Report board software problems here

Post by Lord Revan » 2016-08-12 09:34pm

definetly seems something to do with the board software as YT-embeds elsewhere work just fine for me.
I may be an idiot, but I'm a tolerated idiot
"I think you completely missed the point of sigs. They're supposed to be completely homegrown in the fertile hydroponics lab of your mind, dried in your closet, rolled, and smoked...
Oh wait, that's marijuana..."Einhander Sn0m4n

User avatar
Wild Zontargs
Padawan Learner
Posts: 349
Joined: 2010-07-06 01:24pm

Re: Report board software problems here

Post by Wild Zontargs » 2016-08-14 12:10pm

It seems to be a combination of phpBB's Youtube functionality and the Flash plugin. If you're on a non-phpBB site, it works. If you're on a browser/platform that can't or won't use the Flash version of Youtube, it works. I'm guessing YT changed something that broke the Flash version on phpBB.
Доверяй, но проверяй
"Ugh. I hate agreeing with Zontargs." -- Alyrium Denryle
"What you are is abject human trash who is very good at dodging actual rule violations while still being human trash." -- Alyrium Denryle
iustitia socialis delenda est

User avatar
Wild Zontargs
Padawan Learner
Posts: 349
Joined: 2010-07-06 01:24pm

Re: Report board software problems here

Post by Wild Zontargs » 2016-08-14 03:44pm

Here's a troubleshooting thread on the phpBB site: https://www.phpbb.com/community/viewtop ... p=14499411

[Edit] and another: https://www.phpbb.com/community/viewtop ... 6&t=684875

Sounds like YouTube changed their SWF file, breaking the current phpBB implementation for anyone using Flash.
Доверяй, но проверяй
"Ugh. I hate agreeing with Zontargs." -- Alyrium Denryle
"What you are is abject human trash who is very good at dodging actual rule violations while still being human trash." -- Alyrium Denryle
iustitia socialis delenda est

User avatar
Dominus Atheos
Sith Marauder
Posts: 3719
Joined: 2005-09-15 09:41pm
Location: Portland, Oregon

Re: Report board software problems here

Post by Dominus Atheos » 2016-08-14 05:48pm

So it sounds like a workaround would be to use html5. go to the page and see what it says.

https://www.youtube.com/html5

PS all youtube videos work fine for me, but they are using html5.

User avatar
SpottedKitty
Jedi Knight
Posts: 894
Joined: 2014-08-22 08:24pm
Location: UK

Re: Report board software problems here

Post by SpottedKitty » 2016-08-14 07:50pm

That sounds plausible, but how would it explain the many (but not all) cases where I can see the video properly when I view the forum page later, or when it's quoted?
“Despite rumor, Death isn't cruel — merely terribly, terribly good at his job.”
Terry Pratchett, Sourcery

User avatar
Wild Zontargs
Padawan Learner
Posts: 349
Joined: 2010-07-06 01:24pm

Re: Report board software problems here

Post by Wild Zontargs » 2016-08-14 08:37pm

Well, the admin at another phpBB forum got a working solution out of this thread: https://www.phpbb.com/community/viewtop ... 6&t=684875

And now we're back to having working Flash-based YouTube over there. :mrgreen:
Доверяй, но проверяй
"Ugh. I hate agreeing with Zontargs." -- Alyrium Denryle
"What you are is abject human trash who is very good at dodging actual rule violations while still being human trash." -- Alyrium Denryle
iustitia socialis delenda est

User avatar
Dominus Atheos
Sith Marauder
Posts: 3719
Joined: 2005-09-15 09:41pm
Location: Portland, Oregon

Re: Report board software problems here

Post by Dominus Atheos » 2016-08-14 08:45pm

SpottedKitty wrote:That sounds plausible, but how would it explain the many (but not all) cases where I can see the video properly when I view the forum page later, or when it's quoted?
Did you click that link? Was everything green?

All browsers should be defaulting to html5 by now, if yours is only doing so sometimes, that's a separate issue that we can probably resolve even before Mike updates the forum software.

User avatar
SpottedKitty
Jedi Knight
Posts: 894
Joined: 2014-08-22 08:24pm
Location: UK

Re: Report board software problems here

Post by SpottedKitty » 2016-08-14 09:38pm

Dominus Atheos wrote:Did you click that link? Was everything green?

All browsers should be defaulting to html5 by now, if yours is only doing so sometimes, that's a separate issue that we can probably resolve even before Mike updates the forum software.
Yes, all the support categories listed were ticked. I'm using the current Firefox.

As for HTML5 page content, quite a few of the sites I visit regularly use it and I've never had a problem with it before.
“Despite rumor, Death isn't cruel — merely terribly, terribly good at his job.”
Terry Pratchett, Sourcery

User avatar
Dominus Atheos
Sith Marauder
Posts: 3719
Joined: 2005-09-15 09:41pm
Location: Portland, Oregon

Re: Report board software problems here

Post by Dominus Atheos » 2016-08-15 04:44am

I figured out the problem and posted the fix on the phpbb forums:
I wrote:The problem seems to be with the url that the code is trying to load. #www.youtube.com/v/(video id) is't working at all, in any context. You need to change to #www.youtube.com/embed/(video id).

See http://www.youtube.com/v/frdj1zb9sMY vs http://www.youtube.com/embed/frdj1zb9sMY

See? /embed/ works, /v/ doesn't.



And the reason it's working on the latest firefox but not chrome is because of a feature firefox added 1 version ago, Youtube Embedded Rewrite, which dynamically rewrites any webpage loaded in firefox to use HTML5 instead of Flash which is what the current phpbb code is using, and switches /v/ to /embed/.
Dominus Atheos wrote:Also, the <object> tag that the extension's code uses is deprecated. Google wants everyone to use iframes now.
The deprecation of the YouTube JavaScript Player API was announced on January 27, 2015. YouTube Flash <object> embeds have also been deprecated. See the deprecation policy for more information. Please migrate your applications to the IFrame API, which can intelligently use whichever embedded player – HTML (<video>) or Flash (<object>) – the client supports.
https://developers.google.com/youtube/js_api_reference

Like I said, Firefox 47 and 48 do this automatically without you even noticing.

User avatar
SpottedKitty
Jedi Knight
Posts: 894
Joined: 2014-08-22 08:24pm
Location: UK

Re: Report board software problems here

Post by SpottedKitty » 2016-08-15 10:52am

My mistake, I was still on Firefox v47.0 — I just updated to 48.0 and I seem to be seeing more videos. Fingers crossed...
“Despite rumor, Death isn't cruel — merely terribly, terribly good at his job.”
Terry Pratchett, Sourcery

User avatar
Elheru Aran
Emperor's Hand
Posts: 12400
Joined: 2004-03-04 01:15am
Location: Georgia

Re: Report board software problems here

Post by Elheru Aran » 2016-09-21 11:29am

Board down briefly this morning. I know TimothyC and Ace also experienced it being down as they commented on FB.
It's a strange world. Let's keep it that way.

User avatar
Wild Zontargs
Padawan Learner
Posts: 349
Joined: 2010-07-06 01:24pm

Re: Report board software problems here

Post by Wild Zontargs » 2016-09-24 11:24am

The board has been up and down like a yo-yo the last few days.
Доверяй, но проверяй
"Ugh. I hate agreeing with Zontargs." -- Alyrium Denryle
"What you are is abject human trash who is very good at dodging actual rule violations while still being human trash." -- Alyrium Denryle
iustitia socialis delenda est

User avatar
Broomstick
Emperor's Hand
Posts: 25804
Joined: 2004-01-02 07:04pm
Location: Industrial armpit of the US Midwest
Contact:

Re: Report board software problems here

Post by Broomstick » 2016-09-24 04:55pm

Yes. I'm getting that on a LOT of sites.

I am suspicious but have no way to prove the following:

There is a ransomware virus out there called "LockyEnc.A.gen!Camelot" or some variant of that making the rounds. It has affected Blizzard and Steam, for just two big names, and probably a bunch more. Apparently this bug, instead of hiding in e-mail attachments, can zap you when you visit a website.

Meanwhile, a lot of homepages of people I know (including mine) have been up and down like a yo-yo for the past few days.

So... UPDATE AND KEEP CURRENT YOUR ANTI-VIRUS AND FIREWALL! Keeping mine current is why I haven't been infected so far.

Or maybe something else is going on along with "Locky". I'm not an expert at this.
A life is like a garden. Perfect moments can be had, but not preserved, except in memory. Leonard Nimoy.

Now I did a job. I got nothing but trouble since I did it, not to mention more than a few unkind words as regard to my character so let me make this abundantly clear. I do the job. And then I get paid.- Malcolm Reynolds, Captain of Serenity, which sums up my feelings regarding the lawsuit discussed here.

If a free society cannot help the many who are poor, it cannot save the few who are rich. - John F. Kennedy

Sam Vimes Theory of Economic Injustice

User avatar
General Zod
Never Shuts Up
Posts: 29205
Joined: 2003-11-18 03:08pm
Location: The Clearance Rack
Contact:

Re: Report board software problems here

Post by General Zod » 2016-09-25 12:36am

Broomstick wrote:Yes. I'm getting that on a LOT of sites.

I am suspicious but have no way to prove the following:

There is a ransomware virus out there called "LockyEnc.A.gen!Camelot" or some variant of that making the rounds. It has affected Blizzard and Steam, for just two big names, and probably a bunch more. Apparently this bug, instead of hiding in e-mail attachments, can zap you when you visit a website.

Meanwhile, a lot of homepages of people I know (including mine) have been up and down like a yo-yo for the past few days.

So... UPDATE AND KEEP CURRENT YOUR ANTI-VIRUS AND FIREWALL! Keeping mine current is why I haven't been infected so far.

Or maybe something else is going on along with "Locky". I'm not an expert at this.
It probably attacks you through javascript or flash. Turning both of those off will go a lot further for security than updating your antivirus.
"It's you Americans. There's something about nipples you hate. If this were Germany, we'd be romping around naked on the stage here."

Image

ImageImage

User avatar
Ace Pace
Hardware Lover
Posts: 8241
Joined: 2002-07-07 03:04am
Location: Wasting time instead of money
Contact:

Re: Report board software problems here

Post by Ace Pace » 2016-09-25 01:26am

General Zod wrote:
Broomstick wrote:Yes. I'm getting that on a LOT of sites.

I am suspicious but have no way to prove the following:

There is a ransomware virus out there called "LockyEnc.A.gen!Camelot" or some variant of that making the rounds. It has affected Blizzard and Steam, for just two big names, and probably a bunch more. Apparently this bug, instead of hiding in e-mail attachments, can zap you when you visit a website.

Meanwhile, a lot of homepages of people I know (including mine) have been up and down like a yo-yo for the past few days.

So... UPDATE AND KEEP CURRENT YOUR ANTI-VIRUS AND FIREWALL! Keeping mine current is why I haven't been infected so far.

Or maybe something else is going on along with "Locky". I'm not an expert at this.
It probably attacks you through javascript or flash. Turning both of those off will go a lot further for security than updating your antivirus.
I'll repeat what I've previously said in GE&C. Run a fully patched up to date operating system (Windows, OS X, whatever) and don't execute unknown executables, you're safe from the vast majority of threats.
Brotherhood of the Bear | HAB | Mess | SDnet archivist |

Post Reply